Aktuelle Zeit: Sa 25. Mai 2019, 09:04



Ein neues Thema erstellen Auf das Thema antworten  [ 1 Beitrag ] 
 XFS defragmentieren auf einer Linkstation 400er Serie 
Autor Nachricht
Foren-Mitglied
Foren-Mitglied

Registriert: Mi 9. Apr 2014, 15:25
Beiträge: 107


Bedankte sich: 8 mal
Erhielt: 2 Danksagungen in 1 Beiträgen

Bedanke dich für den Beitrag 
Beitrag XFS defragmentieren auf einer Linkstation 400er Serie
Die Vorgänger, Kirkwood- Serie, hat auch über ipkg keinen Befehl xfs_fsr
Hier kann man nicht defragmentieren.



Linux: XFS defragmentieren

So findet ihr euren Mount Punkt:
Code:
[root@Nas tmp]# df
Filesystem                Size      Used Available Use% Mounted on
udev                     10.0M         0     10.0M   0% /dev
/dev/md1                  4.7G    764.1M      3.7G  17% /
tmpfs                   249.0M    328.0K    248.6M   0% /tmp
/dev/ram1                15.0M    116.0K     14.9M   1% /mnt/ram
/dev/md0                968.7M    212.6M    756.1M  22% /boot
/dev/md10                 3.6T    980.4G      2.7T  27% /mnt/array1
/dev/md10                 3.6T    980.4G      2.7T  27% /opt


Um zu schauen wie weit die Platte (hier meine Raid-Partition) fragmentiert ist, reicht der Befehl:
Code:
# xfs_db -r /dev/md10
xfs_db> frag
actual 415347, ideal 47753, fragmentation factor 88.50%
xfs_db> quit


Ist also zu 88,5% fragmentiert…
Egal.. wir wollen ja defragmentieren :-)
Dies tun wir dann mit folgendem Befehl:
Code:
# xfs_fsr -v /dev/md10


Der -v schalter zeigt die Verbose Meldungen an, damit man auch sehen kann, was er da genau gerade defragmentiert :-)
Das sieht dann in etwa so aus:
Code:
ino=2694406702
extents before:25 after:1 DONE ino=2694406702
ino=2694406700
extents before:23 after:1 DONE ino=2694406700
ino=2694406699
extents before:15 after:1 DONE ino=2694406699
ino=2148008754
extents before:6 after:1 DONE ino=2148008754
ino=2148008755
extents before:6 after:1 DONE ino=2148008755
ino=2148008742
ino=2148008742: file busy
ino=2148008757
extents before:3 after:1 DONE ino=2148008757
ino=2694406698
extents before:3 after:1 DONE ino=2694406698
ino=2148008740


Joah.. jetzt muss man nur noch warten…


Sa 13. Sep 2014, 23:58
Profil
Die folgenden User haben sich bei MrYoshii für diesen Beitrag bedankt:
Jan, oxygen8
Dieser Werbeblock wird nur bei Gästen angezeigt
Beiträge der letzten Zeit anzeigen:  Sortiere nach  

Ein neues Thema erstellen Auf das Thema antworten  [ 1 Beitrag ] 





Suche nach:

Ähnliche Beiträge

Transmission auf einer Linkstation 400er und 200er Serie ohne Optware
Forum: Buffalo Technology NAS - Anleitungen
Autor: oxygen8
Antworten: 0
Lüfterregelung für die 400er Serie
Forum: Buffalo Technology NAS - Anleitungen
Autor: oxygen8
Antworten: 0
rotes Blinken E07 bei der 400er Serie
Forum: Buffalo Technology NAS - Anleitungen
Autor: llothar1972
Antworten: 1
SSH Zugang aus dem Internet absichern am Beispiel der LS 400er Serie
Forum: Buffalo Technology NAS - Anleitungen
Autor: oxygen8
Antworten: 0
ssh freischalten auf einer LS500 Serie (LS520DE)
Forum: Buffalo Technology NAS - Anleitungen
Autor: oxygen8
Antworten: 0

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 39 Gäste


Deine Berechtigungen

 Du darfst keine neuen Themen in diesem Forum erstellen.
 Du darfst keine Antworten zu Themen in diesem Forum erstellen.
 Du darfst deine Beiträge in diesem Forum nicht ändern.
 Du darfst deine Beiträge in diesem Forum nicht löschen.
 Du darfst keine Dateianhänge in diesem Forum erstellen.

Gehe zu:  


| NAS-Hilfe.de - die deutsche Buffalo NAS-Hilfe Seite | Mein Blog - Bloggen Querbeet... | Powered by phpBB © phpBB Group. | Deutsche Übersetzung durch phpBB.de | Impressum |