Aktuelle Zeit: Mo 19. Nov 2018, 09:31



Ein neues Thema erstellen Auf das Thema antworten  [ 11 Beiträge ]  Gehe zu Seite 1, 2  Nächste
 Fehler beim ipkg installieren 
Autor Nachricht
Foren-Benutzer
Foren-Benutzer

Registriert: Do 13. Mai 2010, 09:49
Beiträge: 32


Bedankte sich: 0 mal
Erhielt: 0 Danksagungen in 0 Beiträgen

Bedanke dich für den Beitrag 
Beitrag Fehler beim ipkg installieren
Hallo zusammen,

habe es endlich geschafft meine LS-XHL auf 1.10 zu flashen.
Ich kann mich als root einlogen und den bootstrap über wget runterladen und installieren. Aber leider geht es von hier nicht mehr weiter. ipkg ist irgendwie nicht da und die xhl kennt den Befehl nicht.

Ebenso geht mv /etc/init.d/optware /etc/init.d/rc.optware nicht. Siehe Anhang

Was mache ich falsch?

Bin für jede Hilfe dankbar.

Gruß


Du hast keine ausreichende Berechtigung, um die Dateianhänge dieses Beitrags anzusehen.


Do 13. Mai 2010, 21:56
Profil
Dieser Werbeblock wird nur bei Gästen angezeigt
Globaler Moderator

Registriert: Mo 5. Apr 2010, 23:32
Beiträge: 6554
Bilder: 389

Bedankte sich: 174 mal
Erhielt: 851 Danksagungen in 788 Beiträgen

Bedanke dich für den Beitrag 
Beitrag Re: Fehler beim ipkg installieren
Der Ordner /mnt/disk1/.optware existiert bei dir bereits, bevor du ls-mvkw-bootstrap_1.2-7_arm.xsh startest. Sicherlich hast du schon einmal damit herumgebastelt. Auch nach einem Firmwarewechsel bleibt /mnt/disk1 unagetastet. Somit sind auch Altlasten vorhanden.
Das Script hat dich aber korrekt darauf hingewiesen:

mache:
rm -rf /mnt/disk1/.optware
rm -rf /usr/lib/ipkg

Wobei Letzteres bei mir in dieser Situation nicht vorhanden war.
Reboot
Dann führe ls-mvkw-bootstrap_1.2-7_arm.xsh erneut aus.


Fr 14. Mai 2010, 07:01
Profil Persönliches Album 
Foren-Benutzer
Foren-Benutzer

Registriert: Do 13. Mai 2010, 09:49
Beiträge: 32


Bedankte sich: 0 mal
Erhielt: 0 Danksagungen in 0 Beiträgen

Bedanke dich für den Beitrag 
Beitrag Re: Fehler beim ipkg installieren
Hi jetzt habe ich es "hoffentlich" geschaft ipkg zu installieren. Ich hänge jetzt beim Step wo ich den ipkg updaten soll. Es wurde der Rodner /opt angelegt usw.

Auswelchem Verzeichniss muss ich ipkg es aufrufen?

Bzw. Was kann den jetzt falsch gelaufen sein?

siehe bilder:

Gruß


Du hast keine ausreichende Berechtigung, um die Dateianhänge dieses Beitrags anzusehen.


Fr 14. Mai 2010, 15:11
Profil
Globaler Moderator

Registriert: Mo 5. Apr 2010, 23:32
Beiträge: 6554
Bilder: 389

Bedankte sich: 174 mal
Erhielt: 851 Danksagungen in 788 Beiträgen

Bedanke dich für den Beitrag 
Beitrag Re: Fehler beim ipkg installieren
alles ok
ipkg ist in einem der Pfade und wird gefunden.


Leider ist der Server zur Zeit leer.
http://ipkg.nslu2-linux.org/feeds/optwa ... ss/stable/

Dadurch laufen alle Automatismen ins Leere, wie ipkg list.

Du musst leider alle Pakete selbst aussuchen und einzeln installieren.
Nach dem Beispiel transmission:
1. Paket transmission_1.92-1_arm.ipk saugen und nach share kopieren
2. cd /mnt/disk1/share
3. ipkg install transmission_1.92-1_arm.ipk

Leider kommen nun die Fehlermeldungen mit den Abhängigkeiten.
Jede muss einzeln erfüllt werden.
Mit ipkg list_installed kannst du dir anzeigen lassen, was du installiert hast.
Bei mir sind für Transmission und NFS folgende Pakete instaliert:

e2fslibs
libcurl
libevent
openssl
portmap
transmission
unfs3
wget
zlib

Sobald http://ipkg.nslu2-linux.org/feeds/optwa ... ss/stable/ wieder online ist, geht alles fast automatisch.
Also warte ab, oder gehe Schritt für Schritt vor.


Fr 14. Mai 2010, 16:32
Profil Persönliches Album 
Foren-Benutzer
Foren-Benutzer

Registriert: Do 13. Mai 2010, 09:49
Beiträge: 32


Bedankte sich: 0 mal
Erhielt: 0 Danksagungen in 0 Beiträgen

Bedanke dich für den Beitrag 
Beitrag Re: Fehler beim ipkg installieren
Hi!

Sieht jetzt besser aus.
ipkg reagiert.

Jetzt hab ich aber ein anderes Problem.

Er kann sich nicht updaten. Der Packeteordner im Netz ist auch leer.

http://ftp.osuosl.org/pub/nslu2/feeds/o ... ss/stable/.

update schlägt fehl

und wenn ich ipkg list direkt eingebe heißt es
wget -1.12-2-
Succesfully terminated

das transmission paket fehlt im ja noch un lässt sich nicht installieren

kann man das paket auch manuell in den passenden ordner reinspielen?
bzw. wie änderre ich link für das update.
auf der alternativquelle von dir ist noch alles da?

http://ftp.osuosl.org/pub/nslu2/feeds/o ... ss/stable/

wie kann ich den die ipkg config bearbeiten?
gruß


Du hast keine ausreichende Berechtigung, um die Dateianhänge dieses Beitrags anzusehen.


Fr 14. Mai 2010, 17:27
Profil
Globaler Moderator

Registriert: Mo 5. Apr 2010, 23:32
Beiträge: 6554
Bilder: 389

Bedankte sich: 174 mal
Erhielt: 851 Danksagungen in 788 Beiträgen

Bedanke dich für den Beitrag 
Beitrag Re: Fehler beim ipkg installieren
Ich habe an der Antwort zu lange geschrieben. Nun ist sie über der Frage.

Leider kann ich es nicht testen, aber ich könnte mir vorstellen, dass das IPKG aus Oregon auch auf den eigenen Server ftp.osuosl.org verweist.

Also bitte lösche nochmals deinen optware- Ordner mit
Code:
rm -rf /mnt/disk1/.optware
rm -rf /usr/lib/ipkg


dann weiter mit Telnet:
Code:
cd /tmp ENTER

wget http://ftp.osuosl.org/pub/nslu2/feeds/optware/cs08q1armel/cross/stable/ls-mvkw-bootstrap_1.2-7_arm.xsh ENTER

sh ls-mvkw-bootstrap_1.2-7_arm.xsh ENTER

mv /etc/init.d/optware /etc/init.d/rc.optware

reboot ENTER


wenn du nun
Code:
ipkg install transmission ENTER

eingibst, könnte es sein, dass keine Fehlermeldungen kommen.


Fr 14. Mai 2010, 17:50
Profil Persönliches Album 
Foren-Benutzer
Foren-Benutzer

Registriert: Do 13. Mai 2010, 09:49
Beiträge: 32


Bedankte sich: 0 mal
Erhielt: 0 Danksagungen in 0 Beiträgen

Bedanke dich für den Beitrag 
Beitrag Re: Fehler beim ipkg installieren
Hi nochmal

Die verweisen auch auf den leeren Ordner.
Hab es aber geschafft alles einzeln zu installieren.
Der Remote GUI läuft.

Eine allerletzte Frage noch zu der Anleitung:

h. vi /etc/init.d/smb.sh ENTER
(Notlösung: Ich beende alle Torrents beim Beenden von Samba.)

i. /killall ENTER

j. i

k. /opt/bin/transmission-remote -t all -S ENTER (großes S)

Ich finde bei mir in der vi /etc/init.d/smb.sh dieses "/killall" nicht. Muss das für den automatischen start unbedigt rein?

Muss nur noch eben diesen automatischen Start einrichten, danach werde ich mich vor dir verbeugen :ugeek:
Gruß
Dim


Fr 14. Mai 2010, 19:41
Profil
Globaler Moderator

Registriert: Mo 5. Apr 2010, 23:32
Beiträge: 6554
Bilder: 389

Bedankte sich: 174 mal
Erhielt: 851 Danksagungen in 788 Beiträgen

Bedanke dich für den Beitrag 
Beitrag Re: Fehler beim ipkg installieren
Bitte tippe exakt so wie es da steht.
/killall sucht nach dem String killall
ENTER fügt eine Leerzeile ein
...


Fr 14. Mai 2010, 20:24
Profil Persönliches Album 
Globaler Moderator

Registriert: Mo 5. Apr 2010, 23:32
Beiträge: 6554
Bilder: 389

Bedankte sich: 174 mal
Erhielt: 851 Danksagungen in 788 Beiträgen

Bedanke dich für den Beitrag 
Beitrag Re: Fehler beim ipkg installieren
http://ipkg.nslu2-linux.org/feeds/optwa ... ss/stable/

ist wieder online!

Also allen Bastlern viel Erfolg.


Sa 15. Mai 2010, 04:59
Profil Persönliches Album 
Foren-Benutzer
Foren-Benutzer

Registriert: Do 13. Mai 2010, 09:49
Beiträge: 32


Bedankte sich: 0 mal
Erhielt: 0 Danksagungen in 0 Beiträgen

Bedanke dich für den Beitrag 
Beitrag Re: Fehler beim ipkg installieren
Ich möchte mich an dieser stelle noch mal für deine Unterstützung bedanken. Es läuft jetzt alles soweit perfekt.

Ich habe es bereits vorher über die manuelle Installation geschafft. Da mein ALT nur die 1.92 Transmission akzeptiert, werde ich den eine weile manuell installieren müssen. Aktuell gibt es über ipkg die aktuelle 1.93 Version.

Über die Anleitung von http://buffalo.nas-central.org/wiki/Ope ... are_LS-XHL
habe ich die Firmware 1.26 für meine XHL gepatcht und geflasht. Transmission läuft perfekt über RemoteGui.

@oxygenacht:
Ich habe für mich zum Nachvollziehen eine StepByStep Anleitung ähnlich wie deine geschrieben. Darin enthalten ist das Updaten der LS auf die aktuelle geöffnete 1.26 inkl. der Installation von Tranmission über ipkg und/oder manuell inkl. der Abhängigkeiten und die Einstellung dazu.
Macht es dir was aus, wenn ich Teile davon übernehme? Speziell den Autostart und Shutdownteil? Entfallen wird der telnet Teil, da er hier bereits dauerhaft aktiviert ist.
Ich würde dann die bereits geöffnete Firmware irgendwo uploaden und die Anleitung hier Posten.

Da die FW mit der CHL identisch ist, flashe ich sie heute bei einem Bekannten auf seine CHL drauf.
Hab in den 2 Tagen mehr über linux gelernt als ich eigentlich wollte, naja... schadet nich...

Außer du hast vor deine upzudaten, dann lasse ich es. doppelte Arbeit muss auch nicht sein. Sonnst werden andere Noobs wie ich, die gleiche Fragen stellen, da sie auch die 1.26 haben wollen.

Gruß
Da_Looser


Sa 15. Mai 2010, 14:56
Profil
Beiträge der letzten Zeit anzeigen:  Sortiere nach  

Ein neues Thema erstellen Auf das Thema antworten  [ 11 Beiträge ]  Gehe zu Seite 1, 2  Nächste





Suche nach:

Ähnliche Beiträge

wol installieren mit ipkg
Forum: Buffalo Linkstation Duo
Autor: franc
Antworten: 1
Ipkg Paketmanager auf der Linkstation Live / Pro installieren.
Forum: Artikel - Forum
Autor: Jan
Antworten: 21
IPKG Paketmanager auf der Linkstation ProDuo LS-WTGL/R1 installieren
Forum: Artikel - Forum
Autor: Jan
Antworten: 0
IPKG - Apache2 auf der Linkstation LS-CHL F/W 1.07 wird beim Restart gelöscht
Forum: Buffalo Linkstation Pro/Live mit BitTorrent
Autor: wije
Antworten: 10
Fehler Raid0 wird beim Update von 1.33 auf 1.34 zerstört
Forum: Buffalo Linkstation Pro Duo
Autor: oxygen8
Antworten: 0

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 34 Gäste


Deine Berechtigungen

 Du darfst keine neuen Themen in diesem Forum erstellen.
 Du darfst keine Antworten zu Themen in diesem Forum erstellen.
 Du darfst deine Beiträge in diesem Forum nicht ändern.
 Du darfst deine Beiträge in diesem Forum nicht löschen.
 Du darfst keine Dateianhänge in diesem Forum erstellen.

Gehe zu:  


| NAS-Hilfe.de - die deutsche Buffalo NAS-Hilfe Seite | Mein Blog - Bloggen Querbeet... | Powered by phpBB © phpBB Group. | Deutsche Übersetzung durch phpBB.de | Impressum |