Aktuelle Zeit: Di 12. Dez 2017, 08:44



Ein neues Thema erstellen Auf das Thema antworten  [ 21 Beiträge ]  Gehe zu Seite Vorherige  1, 2, 3  Nächste
 Wie BubbleUPnP Server auf LS-WSXL installieren? 
Autor Nachricht
Globaler Moderator

Registriert: Mo 5. Apr 2010, 23:32
Beiträge: 6364
Bilder: 341

Bedankte sich: 174 mal
Erhielt: 822 Danksagungen in 761 Beiträgen

Bedanke dich für den Beitrag 
Beitrag Re: Wie BubbleUPnP Server auf LS-WSXL installieren?
Code:
echo '/usr/local/ejre1.7.0_60/bin/java -jar /usr/bupnpsvr/BubbleUPnPServer.jar' >/opt/etc/init.d/S96bubble.sh

chmod 755 /opt/etc/init.d/S96bubble.sh

reboot


Viel Erfolg.
Oxy


Mi 23. Jul 2014, 22:41
Profil Persönliches Album 
Dieser Werbeblock wird nur bei Gästen angezeigt
Foren-Neuling
Foren-Neuling

Registriert: So 20. Jul 2014, 16:55
Beiträge: 11


Bedankte sich: 1 mal
Erhielt: 0 Danksagungen in 0 Beiträgen

Bedanke dich für den Beitrag 
Beitrag Re: Wie BubbleUPnP Server auf LS-WSXL installieren?
oxygen8 hat geschrieben:
Code:
echo '/usr/local/ejre1.7.0_60/bin/java -jar /usr/bupnpsvr/BubbleUPnPServer.jar' >/opt/etc/init.d/S96bubble.sh

chmod 755 /opt/etc/init.d/S96bubble.sh

reboot


Viel Erfolg.
Oxy


Hi,

leider hat das so nicht funktioniert oder ich habe was falsch gemacht.

Server startet nach dem Reboot nicht automatisch mit :(

Im Endeffekt habe ich deinen Code in PUTTY kopiert und ausgeführt, dann Reboot.

Gruß
Stefan


Fr 25. Jul 2014, 15:49
Profil
Globaler Moderator

Registriert: Mo 5. Apr 2010, 23:32
Beiträge: 6364
Bilder: 341

Bedankte sich: 174 mal
Erhielt: 822 Danksagungen in 761 Beiträgen

Bedanke dich für den Beitrag 
Beitrag Re: Wie BubbleUPnP Server auf LS-WSXL installieren?
poste mal die Ausgabe von

Code:
cat /opt/etc/init.d/S96bubble.sh


Es kann auch sein, dass Optware vor der Java Umgebung startet.
Dann müsste man eine Pause einbauen.


Fr 25. Jul 2014, 17:48
Profil Persönliches Album 
Foren-Neuling
Foren-Neuling

Registriert: So 20. Jul 2014, 16:55
Beiträge: 11


Bedankte sich: 1 mal
Erhielt: 0 Danksagungen in 0 Beiträgen

Bedanke dich für den Beitrag 
Beitrag Re: Wie BubbleUPnP Server auf LS-WSXL installieren?
oxygen8 hat geschrieben:
poste mal die Ausgabe von

Code:
cat /opt/etc/init.d/S96bubble.sh


Es kann auch sein, dass Optware vor der Java Umgebung startet.
Dann müsste man eine Pause einbauen.


Damit tut sich gar nichts :(


Fr 25. Jul 2014, 20:26
Profil
Globaler Moderator

Registriert: Mo 5. Apr 2010, 23:32
Beiträge: 6364
Bilder: 341

Bedankte sich: 174 mal
Erhielt: 822 Danksagungen in 761 Beiträgen

Bedanke dich für den Beitrag 
Beitrag Re: Wie BubbleUPnP Server auf LS-WSXL installieren?
Dann existiert das Script auch nicht.
Nur der root darf Scripte anlegen, nicht der admin.

Poste alle deine Eingaben und die Ausgaben dazu.


Fr 25. Jul 2014, 20:35
Profil Persönliches Album 
Foren-Neuling
Foren-Neuling

Registriert: So 20. Jul 2014, 16:55
Beiträge: 11


Bedankte sich: 1 mal
Erhielt: 0 Danksagungen in 0 Beiträgen

Bedanke dich für den Beitrag 
Beitrag Re: Wie BubbleUPnP Server auf LS-WSXL installieren?
oxygen8 hat geschrieben:
Dann existiert das Script auch nicht.
Nur der root darf Scripte anlegen, nicht der admin.

Poste alle deine Eingaben und die Ausgaben dazu.


Moin,

habe gestern noch mal etwas rum probiert. Mit Java kam ich nicht weiter, habe daher die S96bubble.sh wie folgt verändert:

Code:
cd /usr/bupnpsvr/ ; sh launch.sh


So hatte es mir BubbleUPnP selbst in einer Fehlermeldung mit Java ausgeben.

Führt man dann manuell die S96bubble.sh aus, so startet der Server auch ordnungsgemäß.

Macht man allerdings einen Reboot der NAS, habe ich wieder das Phänomen, dass die Webconfig-Oberfläche des Servers leer ist, also keine Einträge vorhanden wie beim manuellen Start. Auch ein "Restart" des Servers bringt nichts.

Echt knifflig... :(


Du hast keine ausreichende Berechtigung, um die Dateianhänge dieses Beitrags anzusehen.


Sa 26. Jul 2014, 09:41
Profil
Globaler Moderator

Registriert: Mo 5. Apr 2010, 23:32
Beiträge: 6364
Bilder: 341

Bedankte sich: 174 mal
Erhielt: 822 Danksagungen in 761 Beiträgen

Bedanke dich für den Beitrag 
Beitrag Re: Wie BubbleUPnP Server auf LS-WSXL installieren?
Eine Webconfig ist also nach dem Neustart aktiv.
Dein Startscript läuft also.

Weiter will ich mich da nicht reindenken.


Sa 26. Jul 2014, 11:19
Profil Persönliches Album 
Foren-Neuling
Foren-Neuling

Registriert: So 20. Jul 2014, 16:55
Beiträge: 11


Bedankte sich: 1 mal
Erhielt: 0 Danksagungen in 0 Beiträgen

Bedanke dich für den Beitrag 
Beitrag Re: Wie BubbleUPnP Server auf LS-WSXL installieren?
oxygen8 hat geschrieben:
Eine Webconfig ist also nach dem Neustart aktiv.
Dein Startscript läuft also.

Weiter will ich mich da nicht reindenken.


Jo, das Script funzt... danke dafür.

Bzgl. der anderen Thematik muss ich gucken wie ich das gelöst bekomme.


Sa 26. Jul 2014, 14:02
Profil
Foren-Neuling
Foren-Neuling

Registriert: So 20. Jul 2014, 16:55
Beiträge: 11


Bedankte sich: 1 mal
Erhielt: 0 Danksagungen in 0 Beiträgen

Bedanke dich für den Beitrag 
Beitrag Re: Wie BubbleUPnP Server auf LS-WSXL installieren?
Hi,

mittlerweile ist es so, dass das Script anscheinend gar keine Berücksichtigung mehr findet, denn die Webconfig ist nach einem Reboot des NAS nun nicht mehr erreichbar.

Erst dann, wenn ich entweder die S96bubble.sh manuell ausführe oder eben die launch.sh im BubbleUPnPServer Directory, wird der Server verfügbar.

Gibt es vielleicht doch ein Problem mit dem Script, z.B. dass es vielleicht zu früh gestartet wird?

Liegt es in /opt/etc/init.d/ denn richtig ab oder sollte es vielleicht in /etc/init.d?

Denn generell funktionieren tut es ja.

Danke!

EDIT: Ich glaube die Lösung gefunden zu haben!

Werde das neue Startscript, natürlich mit angepassten Pfaden (Java; BubbleUPnPServer) heute Abend daheim ausprobieren.


Di 29. Jul 2014, 11:09
Profil
Globaler Moderator

Registriert: Mo 5. Apr 2010, 23:32
Beiträge: 6364
Bilder: 341

Bedankte sich: 174 mal
Erhielt: 822 Danksagungen in 761 Beiträgen

Bedanke dich für den Beitrag 
Beitrag Re: Wie BubbleUPnP Server auf LS-WSXL installieren?
Ich will das nicht schon wieder testen, aber bisher hat eine Linkstation FW >1.26 keine Startscripte unter folgendem Pfad ausgeführt:
Zitat:
/etc/rc.d/extensions.d/


Alle hier abgelegten Killscripte werden beim Herunterfahren ausgeführt.


Di 29. Jul 2014, 17:07
Profil Persönliches Album 
Beiträge der letzten Zeit anzeigen:  Sortiere nach  

Ein neues Thema erstellen Auf das Thema antworten  [ 21 Beiträge ]  Gehe zu Seite Vorherige  1, 2, 3  Nächste





Suche nach:

Ähnliche Beiträge

NFS Server installieren
Forum: Buffalo Linkstation Pro/Live
Autor: Jan
Antworten: 13
Twonky Server 5.1.3 auf LS-XHL v3 installieren???
Forum: Buffalo Linkstation Pro/Live mit BitTorrent
Autor: oxygen8
Antworten: 3
Twonky Server installieren
Forum: Buffalo Linkstation Pro Duo
Autor: moustik
Antworten: 19
TwonkyMedia Server Version 5.0 Beta 1 auf der Linkstation Pro Duo LS-WTGL/R1 installieren.
Forum: Artikel - Forum
Autor: Guest
Antworten: 30
App für Buffalonas LS-WSXL
Forum: Buffalo Linkstation Mini
Autor: Lensen
Antworten: 6

Wer ist online?

Mitglieder in diesem Forum: Majestic-12 [Bot] und 3 Gäste


Deine Berechtigungen

 Du darfst keine neuen Themen in diesem Forum erstellen.
 Du darfst keine Antworten zu Themen in diesem Forum erstellen.
 Du darfst deine Beiträge in diesem Forum nicht ändern.
 Du darfst deine Beiträge in diesem Forum nicht löschen.
 Du darfst keine Dateianhänge in diesem Forum erstellen.

Gehe zu:  


| NAS-Hilfe.de - die deutsche Buffalo NAS-Hilfe Seite | Mein Blog - Bloggen Querbeet... | Powered by phpBB © phpBB Group. | Deutsche Übersetzung durch phpBB.de | Impressum |