Aktuelle Zeit: Do 24. Aug 2017, 08:43



Ein neues Thema erstellen Auf das Thema antworten  [ 45 Beiträge ]  Gehe zu Seite 1, 2, 3, 4, 5  Nächste
 Linkstation ProDuo LS-WVL - SSH Root Zugriff in der Firmware 1.41 freischalten 
Autor Nachricht
Foren Triple-As
Foren Triple-As
Benutzeravatar

Registriert: Sa 28. Feb 2009, 13:52
Beiträge: 1573
Bilder: 33
Wohnort: Lohsa

Bedankte sich: 104 mal
Erhielt: 70 Danksagungen in 63 Beiträgen

Bedanke dich für den Beitrag 
Beitrag Linkstation ProDuo LS-WVL - SSH Root Zugriff in der Firmware 1.41 freischalten
Wer die Firmware 1.41 auf seinem NAS installiert hat wird schnell bemerken das er weder per Telnet noch per SSH Zugriff auf seine Linkstation erlangen kann. Telnet ist in der original Firmware Version 1.41 nicht mehr enthalten, SSH muss erst freigeschalten werden bevor es benutzt werden kann.

Diese kurze deutsche Anleitung basiert auf der englischen Original-Anleitung von tenchinho im Nachbarforum NAS-Central. Getestet ist sie unter Windows XP und meiner Linkstation ProDuo LS-WVL, sie funktioniert aber genauso bei den anderen Buffalo Linkstationen der neuesten Generation.

Im Original Beitrag weiterlesen...


Web-Visitenkarte inklusive einer de Domain für nur 99 Cent | Bestellen Sie jetzt Ihren kostenlosen Testaccount



Di 3. Mai 2011, 19:23
Profil Persönliches Album Website besuchen
Dieser Werbeblock wird nur bei Gästen angezeigt
Globaler Moderator

Registriert: Mo 5. Apr 2010, 23:32
Beiträge: 6228
Bilder: 333

Bedankte sich: 173 mal
Erhielt: 800 Danksagungen in 739 Beiträgen

Bedanke dich für den Beitrag 
Beitrag Re: Linkstation ProDuo LS-WVL - SSH Root Zugriff in der Firmware 1.41 freischalten
Danke für die Anleitung. Wenn es deine Zeit erlaubt, würde ich mich über eine Anleitung für einen Telnetzugang als root freuen.


Di 3. Mai 2011, 22:54
Profil Persönliches Album 
Foren Triple-As
Foren Triple-As
Benutzeravatar

Registriert: Sa 28. Feb 2009, 13:52
Beiträge: 1573
Bilder: 33
Wohnort: Lohsa

Bedankte sich: 104 mal
Erhielt: 70 Danksagungen in 63 Beiträgen

Bedanke dich für den Beitrag 
Beitrag Re: Linkstation ProDuo LS-WVL - SSH Root Zugriff in der Firmware 1.41 freischalten
oxygenacht hat geschrieben:
Danke für die Anleitung. Wenn es deine Zeit erlaubt, würde ich mich über eine Anleitung für einen Telnetzugang als root freuen.


Oje, da muss ich aber tief in der Firmware graben. Telnet soll ja gar nicht erst vorhanden sein. Das würde bedeuten das man diese Funktionalität nachrüsten muss. Wenn ich allerdings ins verzeichnis /usr/bin/ auf der Linkstation schaue sehe ich telnet. Es ist also nach meiner Meinung in jedem Fall in der Firmware vorhanden. Ich schaue mir das nochmal genauer an, Twonky braucht ja Telnet Root.

Freundliche Grüsse
Jan


Web-Visitenkarte inklusive einer de Domain für nur 99 Cent | Bestellen Sie jetzt Ihren kostenlosen Testaccount



Di 3. Mai 2011, 23:22
Profil Persönliches Album Website besuchen
Globaler Moderator

Registriert: Mo 5. Apr 2010, 23:32
Beiträge: 6228
Bilder: 333

Bedankte sich: 173 mal
Erhielt: 800 Danksagungen in 739 Beiträgen

Bedanke dich für den Beitrag 
Beitrag Re: Linkstation ProDuo LS-WVL - SSH Root Zugriff in der Firmware 1.41 freischalten
Telnet ist leider nur ein Client. Wir brauchen den telnetd als Server. Der telnetd aus den executeables von FW 1.24 sollte aber gehen. Ich werde das später mal testen.


Mi 4. Mai 2011, 02:05
Profil Persönliches Album 
Foren Triple-As
Foren Triple-As
Benutzeravatar

Registriert: Sa 28. Feb 2009, 13:52
Beiträge: 1573
Bilder: 33
Wohnort: Lohsa

Bedankte sich: 104 mal
Erhielt: 70 Danksagungen in 63 Beiträgen

Bedanke dich für den Beitrag 
Beitrag Re: Linkstation ProDuo LS-WVL - SSH Root Zugriff in der Firmware 1.41 freischalten
Da hast du natürlich recht ist nur der Client vorhanden. Ich habe nun mal telnetd aus einer früheren Version nach /usr/sbin/ kopiert, ausführbar gemacht, und versucht zu starten. Geht leider nicht kommt eine Fehlermeldung. Eventuell hilft es ja telnetd aus der Firmware 1.24 oder 1.37 zu extrahieren?

Freundliche Grüsse
Jan


Web-Visitenkarte inklusive einer de Domain für nur 99 Cent | Bestellen Sie jetzt Ihren kostenlosen Testaccount



Mi 4. Mai 2011, 08:02
Profil Persönliches Album Website besuchen
Foren-Neuling
Foren-Neuling

Registriert: So 8. Mai 2011, 10:45
Beiträge: 21


Bedankte sich: 1 mal
Erhielt: 0 Danksagungen in 0 Beiträgen

Bedanke dich für den Beitrag 
Beitrag Re: Linkstation ProDuo LS-WVL - SSH Root Zugriff in der Firmware 1.41 freischalten
Bei mir hat das leider nicht funktioniert, bekomme keine SSH Verbindung. Vielleicht kann jemand die Ausgabe der DOS-Box interpretieren? (habe mein passwort für die Prozedur tatsächlich auf adminpasswort geändert). Die Fehlermeldungen sollte man doch eigentlich ignorieren können, da sie keine relevanten befehle betreffen?


Code:
C:\>java -jar acp_commander.jar -t 10.0.0.130 -ip 10.0.0.130 -pw adminpasswort -
c "(echo adminpasswort;echo adminpasswort)|passwd"
ACP_commander out of the nas-central.org (linkstationwiki.net) project.
Used to send ACP-commands to Buffalo linkstation(R) LS-PRO.

WARNING: This is experimental software that might brick your linkstation!


Using random connID value = DED68DE28525
Using target:   LS-CHLD26.home/10.0.0.130
Starting authentication procedure...
Sending Discover packet...
Found:  LS-CHLD26 (/10.0.0.130)         LS-CHL(YURYAKU) (ID=00018)      mac: ***  Firmware=  1.410        Key=***
Trying to authenticate EnOneCmd...      ACP_STATE_OK
Trying to authenticate with admin password...   ACP_STATE_OK
>(echo adminpasswort;echo adminpasswort)|passwd
OK (ACP_STATE_OK)
Changeing IP:   ACP_STATE_PASSWORD_ERROR
Please note, that the current support for the change of the IP is currently very
rudimentary.
The IP has been set to the given, fixed IP, however DNS and gateway have not bee
n set. Use the WebGUI to make appropriate settings.

C:\>java -jar acp_commander.jar -t 10.0.0.130 -ip 10.0.0.130 -pw adminpasswort -
c "sed -i 's/UsePAM yes/UsePAM no/g' /etc/sshd_config"
ACP_commander out of the nas-central.org (linkstationwiki.net) project.
Used to send ACP-commands to Buffalo linkstation(R) LS-PRO.

WARNING: This is experimental software that might brick your linkstation!


Using random connID value = 66052D442606
Using target:   LS-CHLD26.home/10.0.0.130
Starting authentication procedure...
Sending Discover packet...
Found:  LS-CHLD26 (/10.0.0.130)         LS-CHL(YURYAKU) (ID=00018)      mac: ***  Firmware=  1.410        Key=***
Trying to authenticate EnOneCmd...      ACP_STATE_OK
Trying to authenticate with admin password...   ACP_STATE_OK
>sed -i 's/UsePAM yes/UsePAM no/g' /etc/sshd_config
OK (ACP_STATE_OK)
Changeing IP:   ACP_STATE_PASSWORD_ERROR
Please note, that the current support for the change of the IP is currently very
rudimentary.
The IP has been set to the given, fixed IP, however DNS and gateway have not bee
n set. Use the WebGUI to make appropriate settings.

C:\>java -jar acp_commander.jar -t 10.0.0.130 -ip 10.0.0.130 -pw adminpasswort -
c "sed -i 's/PermitRootLogin no/PermitRootLogin yes/g' /etc/sshd_config"
ACP_commander out of the nas-central.org (linkstationwiki.net) project.
Used to send ACP-commands to Buffalo linkstation(R) LS-PRO.

WARNING: This is experimental software that might brick your linkstation!


Using random connID value = 8EF5E593CB86
Using target:   LS-CHLD26.home/10.0.0.130
Starting authentication procedure...
Sending Discover packet...
Found:  LS-CHLD26 (/10.0.0.130)         LS-CHL(YURYAKU) (ID=00018)      mac: ***  Firmware=  1.410        Key=***
Trying to authenticate EnOneCmd...      ACP_STATE_OK
Trying to authenticate with admin password...   ACP_STATE_OK
>sed -i 's/PermitRootLogin no/PermitRootLogin yes/g' /etc/sshd_config
OK (ACP_STATE_OK)
Changeing IP:   ACP_STATE_PASSWORD_ERROR
Please note, that the current support for the change of the IP is currently very
rudimentary.
The IP has been set to the given, fixed IP, however DNS and gateway have not bee
n set. Use the WebGUI to make appropriate settings.

C:\>java -jar acp_commander.jar -t 10.0.0.130 -ip 10.0.0.130 -pw adminpasswort -
c "/etc/init.d/sshd.sh restart"
ACP_commander out of the nas-central.org (linkstationwiki.net) project.
Used to send ACP-commands to Buffalo linkstation(R) LS-PRO.

WARNING: This is experimental software that might brick your linkstation!


Using random connID value = 6111B384C264
Using target:   LS-CHLD26.home/10.0.0.130
Starting authentication procedure...
Sending Discover packet...
Found:  LS-CHLD26 (/10.0.0.130)         LS-CHL(YURYAKU) (ID=00018)      mac: ***  Firmware=  1.410        Key=***
Trying to authenticate EnOneCmd...      ACP_STATE_OK
Trying to authenticate with admin password...   ACP_STATE_OK
>/etc/init.d/sshd.sh restart
OK (ACP_STATE_OK)
Changeing IP:   ACP_STATE_PASSWORD_ERROR
Please note, that the current support for the change of the IP is currently very
rudimentary.
The IP has been set to the given, fixed IP, however DNS and gateway have not bee
n set. Use the WebGUI to make appropriate settings.

C:\>


So 15. Mai 2011, 12:51
Profil
Globaler Moderator

Registriert: Mo 5. Apr 2010, 23:32
Beiträge: 6228
Bilder: 333

Bedankte sich: 173 mal
Erhielt: 800 Danksagungen in 739 Beiträgen

Bedanke dich für den Beitrag 
Beitrag Re: Linkstation ProDuo LS-WVL - SSH Root Zugriff in der Firmware 1.41 freischalten
Die letzte Meldung sollte so aussehen:

Code:
...
Trying to authenticate EnOneCmd...      ACP_STATE_OK
Trying to authenticate with admin password...   ACP_STATE_OK
>/etc/init.d/sshd.sh restart
load_info ItemValue = off
LoadConfFileStringEx:key=[ad_dns] not found in /etc/melco/info.
LoadConfFileOnOffEx:key=[info_visible] not found in /etc/melco/info.
LoadConfFileStringEx:key=[array1] not found in /etc/melco/diskinfo.
LoadConfFileStringEx:key=[array2] not found in /etc/melco/diskinfo.
LoadConfFileStringEx:key=[usb_disk2] not found in /etc/melco/diskinfo.
file:/etc/sftponly_config
userinfo finished
groupname admin
groupname guest
groupname hdusers
file:/etc/pam.d/sshd

Changeing IP:   ACP_STATE_PASSWORD_ERROR
Please note, that the current support for the change of the IP is currently very
rudimentary.
The IP has been set to the given, fixed IP, however DNS and gateway have not bee
n set. Use the WebGUI to make appropriate settings.




Hast du bei deinem wegelassenen Befehl
Code:
-c "ls /"
eine Antwort bekommen? Wenn nicht brauchst du nicht weiter machen. Suche erst einmal den Fehler.


Einen Neustart der Box solltest du auch versuchen.


So 15. Mai 2011, 13:02
Profil Persönliches Album 
Foren-Neuling
Foren-Neuling

Registriert: So 8. Mai 2011, 10:45
Beiträge: 21


Bedankte sich: 1 mal
Erhielt: 0 Danksagungen in 0 Beiträgen

Bedanke dich für den Beitrag 
Beitrag Re: Linkstation ProDuo LS-WVL - SSH Root Zugriff in der Firmware 1.41 freischalten
Neustart habe ich schon gestern versucht ;)
und
ls /
zeigt die ordner an


So 15. Mai 2011, 13:51
Profil
Globaler Moderator

Registriert: Mo 5. Apr 2010, 23:32
Beiträge: 6228
Bilder: 333

Bedankte sich: 173 mal
Erhielt: 800 Danksagungen in 739 Beiträgen

Bedanke dich für den Beitrag 
Beitrag Re: Linkstation ProDuo LS-WVL - SSH Root Zugriff in der Firmware 1.41 freischalten
Versuche es erneut, bis dir der sshd antwortet.


So 15. Mai 2011, 14:01
Profil Persönliches Album 
Foren-Neuling
Foren-Neuling

Registriert: So 8. Mai 2011, 10:45
Beiträge: 21


Bedankte sich: 1 mal
Erhielt: 0 Danksagungen in 0 Beiträgen

Bedanke dich für den Beitrag 
Beitrag Re: Linkstation ProDuo LS-WVL - SSH Root Zugriff in der Firmware 1.41 freischalten
Hmm, nochmal neu gestartet, noch dreimal die vier befehle durch, Fehlanzeige ...
kann es irgendwie damit zu tun haben, dass mein privates netz mit 10. und nicht mit 192. beginnt?


So 15. Mai 2011, 14:17
Profil
Beiträge der letzten Zeit anzeigen:  Sortiere nach  

Ein neues Thema erstellen Auf das Thema antworten  [ 45 Beiträge ]  Gehe zu Seite 1, 2, 3, 4, 5  Nächste





Suche nach:

Ähnliche Beiträge

Wie flashe ich die Firmware der Linkstation ProDuo LS-WTGL/R1
Forum: Artikel - Forum
Autor: Jan
Antworten: 0
Root FTP Zugriff auf LS WXL
Forum: Buffalo Linkstation Duo
Autor: audi15
Antworten: 8
Root Zugriff
Forum: Buffalo Linkstation Duo
Autor: chrisbra
Antworten: 2
Telnet oder SSH Zugriff auf eigenem Image freischalten
Forum: Buffalo Linkstation Pro/Live mit BitTorrent
Autor: oxygen8
Antworten: 17
Firmware 1.60 telnet / SSH freischalten
Forum: Buffalo Linkstation Pro Duo
Autor: oxygen8
Antworten: 3

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 2 Gäste


Deine Berechtigungen

 Du darfst keine neuen Themen in diesem Forum erstellen.
 Du darfst keine Antworten zu Themen in diesem Forum erstellen.
 Du darfst deine Beiträge in diesem Forum nicht ändern.
 Du darfst deine Beiträge in diesem Forum nicht löschen.
 Du darfst keine Dateianhänge in diesem Forum erstellen.

Gehe zu:  


cron
| NAS-Hilfe.de - die deutsche Buffalo NAS-Hilfe Seite | Mein Blog - Bloggen Querbeet... | Powered by phpBB © phpBB Group. | Deutsche Übersetzung durch phpBB.de | Impressum |