Aktuelle Zeit: Do 14. Dez 2017, 02:37



Ein neues Thema erstellen Auf das Thema antworten  [ 11 Beiträge ]  Gehe zu Seite 1, 2  Nächste
 Die Firmware der Linkstation Live LS-CHL von Firmware - Version 1.21 (ohne Telnet) auf die Firmware - Version 1.10 (mit Telnet) downgraden 
Autor Nachricht
Foren Triple-As
Foren Triple-As
Benutzeravatar

Registriert: Sa 28. Feb 2009, 13:52
Beiträge: 1573
Bilder: 33
Wohnort: Lohsa

Bedankte sich: 104 mal
Erhielt: 70 Danksagungen in 63 Beiträgen

Bedanke dich für den Beitrag 
Beitrag Die Firmware der Linkstation Live LS-CHL von Firmware - Version 1.21 (ohne Telnet) auf die Firmware - Version 1.10 (mit Telnet) downgraden
Besitzer einer Buffalo Linkstation Live LS-CHL ab der Firmware Version 1.21 haben leider das Problem das auf ihr NAS weder ein Telnet noch ein SSH Zugriff möglich ist. Beide Funktionen wurden von Buffalo Technology aus der Firmware entfernt.

Wie wichtig jedoch ein Telnet Root Zugang zum NAS ist, wird spätestens dann klar wenn man beispielsweise den integrierten Medienserver, einen Twonky 4.4.8, auf eine spätere Version Updaten möchte. Ein solches Vorhaben ist ab der Firmware Version 1.21 auf der LS-CHL nicht mehr möglich. Ebenso entfällt die Möglichkeit den IPKG-Paketmanager auf dem NAS zu installieren um etwa einen Webserver mit PHP und Mysql Unterstützung auf der LS-CHL nachzurüsten.

Was sich Buffalo Technology dabei gedacht hat wird wohl ihr Geheimnis bleiben. Möglicherweise haben Sicherheitsbedenken dazu geführt Telnet aus der Firmware des NAS zu verbannen.

Wer seine Linkstation Live LS-CHL schon etwas länger besitzt weiss das Buffalo Technology das NAS anfangs mit der Firmware 1.10 ausgeliefert hatte, in dieser Firmware-Version war sowohl Telnet als auch SSH enthalten. Leider stellt der Hersteller die 1.10 nicht mehr auf seiner Webseite zum Download bereit. Da im Internet nichts verschwindet oder verloren geht ist es unserem User eTom gelungen die Firmware auf einer japanischen Seite wiederzufinden. Der User Torry hat dann dankenswerter Weise die enthaltene japanische LSUpdater.exe gegen die deutsche Version ausgetauscht. Somit ist es uns nun möglich die Firmware 1.10 mit deutscher LSUpdater.exe zum Download anzubieten.

Im Original Beitrag weiterlesen...


Web-Visitenkarte inklusive einer de Domain für nur 99 Cent | Bestellen Sie jetzt Ihren kostenlosen Testaccount



Di 23. Feb 2010, 18:57
Profil Persönliches Album Website besuchen
Dieser Werbeblock wird nur bei Gästen angezeigt
Foren-Neuling
Foren-Neuling

Registriert: Mo 10. Mai 2010, 18:31
Beiträge: 5


Bedankte sich: 0 mal
Erhielt: 0 Danksagungen in 0 Beiträgen

Bedanke dich für den Beitrag 
Beitrag Re: Die Firmware der Linkstation Live LS-CHL von Firmware - Version 1.21 (ohne Telnet) auf die Firmware - Version 1.10 (mit Telnet) downgraden
Ich habe vermutlich dasselbe Problem (kein Telnet) auf meiner LS-WSX (Linkstation Mini, 1TB).
Allerdings habe ich dafür bisher noch keine ältere Firmware finden können.
Aktuell ist bei mir die 1.26 drauf.
Weiß jemand Rat? Sprich: Wo finde ich eine passende ältere Firmware für mein Modell?


Mo 10. Mai 2010, 18:48
Profil
Globaler Moderator

Registriert: Mo 5. Apr 2010, 23:32
Beiträge: 6369
Bilder: 341

Bedankte sich: 174 mal
Erhielt: 822 Danksagungen in 761 Beiträgen

Bedanke dich für den Beitrag 
Beitrag Re: Die Firmware der Linkstation Live LS-CHL von Firmware - Version 1.21 (ohne Telnet) auf die Firmware - Version 1.10 (mit Telnet) downgraden
Die bereits offene Firmware von Shonk sollte passen:
http://www.shonk.org/Nas/LS-WSXL-124-MOD1a.rar

Werkseinstellung laden um das root-Kennwort zu löschen!


Di 11. Mai 2010, 00:16
Profil Persönliches Album 
Foren-Neuling
Foren-Neuling

Registriert: Mo 10. Mai 2010, 18:31
Beiträge: 5


Bedankte sich: 0 mal
Erhielt: 0 Danksagungen in 0 Beiträgen

Bedanke dich für den Beitrag 
Beitrag Re: Die Firmware der Linkstation Live LS-CHL von Firmware - Version 1.21 (ohne Telnet) auf die Firmware - Version 1.10 (mit Telnet) downgraden
Die Firmware 1.24 zu installieren hat funktioniert, das meldet jedenfalls das Programm LSUpdater - und damit habe auch telnet-Zugang (meldet Portscan), aber ich komme nicht weiter als bis zum login.

Das Laden der Werkseinstellungen funktioniert auch insofern, als dass über die Web-Oberfläche das voreingestellte Passwort wieder akzeptiert wird.

Aber nach der Eingabe des Passworts (über den Browser) kommt sofort die Fehlermeldung "The current session has expired. Please sign in again.", ohne eine Möglichkeit, vorher irgendetwas einzustellen.

Telnet gibt auf jede Passworteingabe (blank, nur Enter-Taste, oder das Web-Passwort) die Rückmeldung "Login incorrect" - unabhängig ob ich die LS zurücksetze oder nicht. :cry:


Di 11. Mai 2010, 21:25
Profil
Globaler Moderator

Registriert: Mo 5. Apr 2010, 23:32
Beiträge: 6369
Bilder: 341

Bedankte sich: 174 mal
Erhielt: 822 Danksagungen in 761 Beiträgen

Bedanke dich für den Beitrag 
Beitrag Re: Die Firmware der Linkstation Live LS-CHL von Firmware - Version 1.21 (ohne Telnet) auf die Firmware - Version 1.10 (mit Telnet) downgraden
Du musst dich mit Telnet als root ohne Kennwort anmelden und mit passwd ein Kennwort erstellen.

Wenn du im Browser ein neues Kennwort für admin eingibst sind die alten Cockies nicht mehr gültig. Drücke F5 für Ansicht aktualisieren oder lösche den Cache und die Cockies.


Mi 12. Mai 2010, 01:27
Profil Persönliches Album 
Foren-Neuling
Foren-Neuling

Registriert: Mo 10. Mai 2010, 18:31
Beiträge: 5


Bedankte sich: 0 mal
Erhielt: 0 Danksagungen in 0 Beiträgen

Bedanke dich für den Beitrag 
Beitrag Re: Die Firmware der Linkstation Live LS-CHL von Firmware - Version 1.21 (ohne Telnet) auf die Firmware - Version 1.10 (mit Telnet) downgraden
Vielleicht stelle ich mich ja ungeschickt an, aber habe praktisch kaum Erfahrungen mit telnet und habe es bisher nicht geschafft, mich als root ohne Kennwort anzumelden.

Das Ganze sieht bei mir aus wie folgt:
1) Ich starte ein Terminalfenster auf meinem Mac (OS 10.6.3).
2) Ich gebe ein: telnet 192.168.67.45 (IP-Adresse der LS)
3) Das System reagiert mit der Ausgabe
Trying 192.168.67.45...
Connected to ls-wsxla9a.fritz.box.
Escape character is '^]'.
BUFFALO INC. LinkStation series
LS-WSXLA9A login:

4) Soweit so gut. Ich tippe root (und drück die Entertaste)
5) Das System reagiert mit der Ausgabe: Password:
6) Wenn ich nichts eingebe, kriege ich nach 60sek einen Timeout.
7) Wenn ich nur die Entertaste drücke oder irgendetwas anderes eingebe, lautet die Reaktion
Login incorrect
LS-WSXLA9A login:

8) Das war's. Weiter komme ich nicht.
Ich habe in irgendeinem Manual gelesen, dass man einen Server so einstellen kann, dass bei der Eingabe des login gar kein Passwort abgefragt wird, aber wie soll ich das auf der LS einstellen, wenn ich mich vorher gar nicht anmelden kann?
:?


Fr 14. Mai 2010, 11:48
Profil
Globaler Moderator

Registriert: Mo 5. Apr 2010, 23:32
Beiträge: 6369
Bilder: 341

Bedankte sich: 174 mal
Erhielt: 822 Danksagungen in 761 Beiträgen

Bedanke dich für den Beitrag 
Beitrag Re: Die Firmware der Linkstation Live LS-CHL von Firmware - Version 1.21 (ohne Telnet) auf die Firmware - Version 1.10 (mit Telnet) downgraden
Welche Firmware hast du denn geflasht?


Fr 14. Mai 2010, 13:26
Profil Persönliches Album 
Foren-Neuling
Foren-Neuling

Registriert: Mo 10. Mai 2010, 18:31
Beiträge: 5


Bedankte sich: 0 mal
Erhielt: 0 Danksagungen in 0 Beiträgen

Bedanke dich für den Beitrag 
Beitrag Re: Die Firmware der Linkstation Live LS-CHL von Firmware - Version 1.21 (ohne Telnet) auf die Firmware - Version 1.10 (mit Telnet) downgraden
Die du empfohlen hattest:

Die bereits offene Firmware von Shonk sollte passen:
http://www.shonk.org/Nas/LS-WSXL-124-MOD1a.rar


Fr 14. Mai 2010, 13:28
Profil
Globaler Moderator

Registriert: Mo 5. Apr 2010, 23:32
Beiträge: 6369
Bilder: 341

Bedankte sich: 174 mal
Erhielt: 822 Danksagungen in 761 Beiträgen

Bedanke dich für den Beitrag 
Beitrag Re: Die Firmware der Linkstation Live LS-CHL von Firmware - Version 1.21 (ohne Telnet) auf die Firmware - Version 1.10 (mit Telnet) downgraden
Genau.
Gehe bitte in das Webinterface
System
Wiederherstellen/Formatieren
und drücke Linkstation wiederherstellen

Nun ist das root-Kennwort gelöscht.

Also Telnet als root und nur auf Enter hauen.

Sollte dein Browser weiterhin murren, nimm Firefox oder Chrome.


Fr 14. Mai 2010, 17:23
Profil Persönliches Album 
Foren-Neuling
Foren-Neuling

Registriert: Mo 10. Mai 2010, 18:31
Beiträge: 5


Bedankte sich: 0 mal
Erhielt: 0 Danksagungen in 0 Beiträgen

Bedanke dich für den Beitrag 
Beitrag Re: Die Firmware der Linkstation Live LS-CHL von Firmware - Version 1.21 (ohne Telnet) auf die Firmware - Version 1.10 (mit Telnet) downgraden
Ok, habe die LS wie beschrieben wiederhergestellt.
Das wirkt sich so aus, dass jetzt kein Telnet mehr vorhanden ist.
Portscan listet jedenfalls nichts mehr aus 23 (war nach dem Downgrade mit der geflashten Firmware zu sehen) und das telnet-Kommando bewirkt nur noch die Ausgabe telnet: Unable to connect to remote host
:cry:


Fr 14. Mai 2010, 19:48
Profil
Beiträge der letzten Zeit anzeigen:  Sortiere nach  

Ein neues Thema erstellen Auf das Thema antworten  [ 11 Beiträge ]  Gehe zu Seite 1, 2  Nächste





Suche nach:

Ähnliche Beiträge

MySQL Version downgraden ?!
Forum: Buffalo Linkstation Duo
Autor: schnuffelbär
Antworten: 6
Wie LS-XHL mit Firmware 1.26 auf 1.10 richtig downgraden?
Forum: Buffalo Linkstation Pro/Live mit BitTorrent
Autor: Da_Looser
Antworten: 3
Buffalo LS-V1.0TL-EU org. Firmware 1.13, nach Firmware update USB ohne funktion
Forum: Buffalo Linkstation Pro/Live mit BitTorrent
Autor: Hans
Antworten: 2
Twonky Mediaserver Version 5 auf der Linkstation Live / Pro installieren
Forum: Artikel - Forum
Autor: madog
Antworten: 24
Linkstation Live - was ist da los? (EM-Mode, Firmwareupdate usw. ohne Erfolg)
Forum: Buffalo Linkstation Pro/Live
Autor: oxygen8
Antworten: 6

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 6 Gäste


Deine Berechtigungen

 Du darfst keine neuen Themen in diesem Forum erstellen.
 Du darfst keine Antworten zu Themen in diesem Forum erstellen.
 Du darfst deine Beiträge in diesem Forum nicht ändern.
 Du darfst deine Beiträge in diesem Forum nicht löschen.
 Du darfst keine Dateianhänge in diesem Forum erstellen.

Gehe zu:  


cron
| NAS-Hilfe.de - die deutsche Buffalo NAS-Hilfe Seite | Mein Blog - Bloggen Querbeet... | Powered by phpBB © phpBB Group. | Deutsche Übersetzung durch phpBB.de | Impressum |